Why is my item model invisible?  [Solved]

Get help and support for using Cubik Studio.
Post Reply

Why is my item model invisible?

Post by VoxelRabbit » 07 Feb 2020, 22:20

I was following a first few tutorials and set up the best model properties I could to make the item actually work in Minecraft using Cubik Studio, also I made sure I have my resource pack and next thing I noticed when I exported the model, it was invisible as I don't see the GUI icon of the model appeared with the resource pack active, neither do I see the model appeared in the arm.

I don't know what exactly is it that i'm doing wrong when rendering and exporting the model with the atlas texture, but here is a screenshot of how I recently replaced the stone sword with the model. Can someone please help me with this?

Image
x
Last edited by VoxelRabbit on 07 Feb 2020, 22:51, edited 2 times in total.
User avatar
VoxelRabbit
Posts: 3
Joined: 30 Jan 2020, 21:49

Re: Why is my item model invisible?

Post by HanFox » 07 Feb 2020, 22:21

It's hard to know without seeing your JSON file.
x
Create your own thread for purchase/activation/key issues.

Please don't Private Message admins without prior permission. Your message may be missed.
User avatar
HanFox
Web Admin
Posts: 889
Joined: 16 Apr 2012, 00:46
Location: Warwickshire, England

Re: Why is my item model invisible?

Post by VoxelRabbit » 07 Feb 2020, 22:54

HanFox wrote:
07 Feb 2020, 22:21
It's hard to know without seeing your JSON file.
Here's the json file that I have, it's close to the last file I have in my previous thread on this forum
Attachments
gun_model.json
(276.75 KiB) Downloaded 3 times
x
User avatar
VoxelRabbit
Posts: 3
Joined: 30 Jan 2020, 21:49

Re: Why is my item model invisible?  [Solved]

Post by HanFox » 08 Feb 2020, 00:03

Remove the second line:

Code: Select all

"parent": "item/handheld",
x
Create your own thread for purchase/activation/key issues.

Please don't Private Message admins without prior permission. Your message may be missed.
User avatar
HanFox
Web Admin
Posts: 889
Joined: 16 Apr 2012, 00:46
Location: Warwickshire, England

Post Reply

Return to “Help Centre”