Paint Tool locked to certain voxels [Solved]

Get help and support for using Cubik Studio.
Post Reply

Paint Tool locked to certain voxels [Solved]

Post by Kaldron » 02 Nov 2016, 14:09

After using the voxel tool to setup my model, one of my colors disappeared after I converted them to elements. If I try to paint it, it paints the whole model and I see no way to fix it besides going to each and every single tiny cube and setting up a new UV. I was wondering if I can define what the program paints more specifically than an entire group of voxels or if there is no way of doing this in which case I need to start from scratch.
x
User avatar
Kaldron
Early Adopter
Posts: 1
Joined: 01 Nov 2016, 22:16

Re: Paint Tool locked to certain voxels

Post by Sphax » 02 Nov 2016, 18:22

After converting voxels to elements, Cubik is creating a palette and assign each element to a color in that palette.

Paint tool is actually modifying the texture pixels where you clicked on the surface. So if you use pen pain tool and left click on a red surface, the palette will change the red to something else and so all elements with UV pointing there will also change color.

To avoid that, you need to ask Cubik to recalculate a new texture and UVs (this is an advanced function with expert behavior). To do so, go to Material Manager (where textures are listed), click "..." button and select "Create atlas, keep textures". By doing so, Cubik will create a new texture containing unique zones for each face of each element. Bringing you a way to paint safely on your model.

This feature is one of the most advanced Cubik Studio has and is currently probably my favorite one. ;)
x
For support, use forum (not DM or PM or email) and create your own topic :3d:
User avatar
Sphax
Admin
Posts: 1307
Joined: 10 Nov 2011, 10:44

Post Reply

Return to “Help Centre”